## TABLE OF CONTENTS

- VLOOKUP ....................................................................................................................................................................2
- VLOOKUP ....................................................................................................................................................................2
- SUMIF .........................................................................................................................................................................3
- SUMIF .....................................................................................................................................................................3
- PivotTable ...................................................................................................................................................................4
- Create PivotTable ...................................................................................................................................................4
- Build PivotTable ..........................................................................................................................................................5
- PivotChart ...................................................................................................................................................................6
- Chart Types Explained ................................................................................................................................................7
- Conditional Formatting - Basics............................................................................................................................... 11
  - Basic Conditional Formatting .............................................................................................................................. 11
  - Multiple Conditional Formatting Rules ............................................................................................................... 11
  - Managing/Editing Rules....................................................................................................................................... 11
- Conditional Formatting – If Conditions ................................................................................................................... 12
  - Format Cells where other Cells Meet Conditions .............................................................................................. 12
  - Creating IF Statements ........................................................................................................................................ 12
- Build Macro ............................................................................................................................................................. 13
- Enable the Developer Tab ................................................................................................................................... 13
- Record Macro .......................................................................................................................................................... 13
- Run Macro ............................................................................................................................................................. 13
- VB Marcos ................................................................................................................................................................ 14
  - Find Macro Code on the Web ............................................................................................................................... 14
  - Create new VB Generated Macro......................................................................................................................... 14
- Protect Sheet ........................................................................................................................................................... 15
  - Unlock User Enabled Cells .................................................................................................................................. 15
  - Protect Sheet ....................................................................................................................................................... 15
  - Unprotect Sheet ................................................................................................................................................. 15
- Support for Microsoft Excel ..................................................................................................................................... 16
  - Recent Changes to this Document
    - 11/21/2017 – Absolute Cell Referencing page added.
    - 10/24/2018 – Corrections for Pivot Table step action
A VLOOKUP is a simple data look up feature. It allows you to enter a known columnar value within a range of data (an employee ID #), and return a corresponding value (Personnel subarea) per the known value you started with. Enter the persons Personnel # and their Personnel sub area is returned. This is a very helpful when looking for common information in a large data range.

**VLOOKUP**

=VLOOKUP(B1, A10:150, 7, FALSE)

- **Cell you are entering known information (PSID#)**
- **Data range you are searching within (left column of range must be lookup column (PSID#))**
- **Column number counted from left edge of data range where information looking for is found**
- **Argument which creates an exact match**

**NOTE** – If you attempt to use the fill down feature on this formula, you’ll need to use the absolute cell referencing technique, which is found in the Excel II curriculum.
SUMIF

It's very common to total all data in a column. However, many times you want to total columns in a segmented way in which you only sum the numbers in the column if it is that they are related to data in another column. So, rather than total all fruit sales, you wish to total only bananas in the fruit column.

\[
\text{SUMIF(G2:G65, "Bananas", K2:K65)}
\]

- **Data range you want to search for the criteria**
- **The criteria used to determine which cells to sum in the sum range**
- **The sum range containing the values you wish to sum if the criteria is met in the data range**
Being able to quickly analyze data can help you make better business decisions. But sometimes it’s hard to know where to start, especially when you have a lot of data. Pivot tables are a great way to summarize, analyze, explore, and present your data, and you can create them with just a few clicks. Pivot tables are highly flexible and can be quickly adjusted depending on how you need to display your results. You can also create pivot charts based on PivotTables that will automatically update when your pivot tables do.

**Note:** You cannot create a pivot table based on a range that maintains empty columns and or rows.

**CREATE PIVOT TABLE**

1. Place your cursor in the cell where you wish to place the pivot table.
2. Click on the Insert Tab and click on PivotTable.
   
   The Create PivotTable window appears.
3. Under Choose the data that you want to analyze, choose Select a table or range.
4. Click on the Define Range button.
5. Click and drag across the range that contains the data you will develop a pivot table on including the header row.
6. Click on the Define range button again.
   
   You have defined what range will be analyzed.
7. Under Choose where you want the pivot table report to be placed, choose Existing Worksheet.
8. Click on OK.

   You have defined where the pivot table will be placed. A placeholder for the Pivot Table will be placed at the defined location. The PivotTable Fields window shows at the right. The pivot table fields window contains a field list of all your column headings.

**NOTE** – The Pivot Table Fields panel at the right will not show if it is that you select a cell anywhere outside of your Pivot Table placeholder or Pivot Table data. The inverse is true, in that, in order to see the Pivot Table Fields panel, you’ll need to click on the Pivot Table place holder or place your cursor somewhere in the pivot table data.

CONTINUED...
BUILD PIVOTTABLE

1. Click on the Pivot Table placeholder or place your cursor in any cell within the pivot table data

   The pivot table fields window displays at the right. The pivot table fields window contains a field list of all your column headings.

2. In the listed fields place a checkmark on the field you wish to become your categorical data (rows in the Pivot Table data range)

   The selected field will place itself in the ROWS area at right. The select field’s data array will display as the rows of your pivot table.

3. In the listed fields place a checkmark on the field you wish to become your series data (columns in the Pivot Table data range)

   The selected field will also place itself in the ROWS area at right.

4. Drag the field you wish to become series data into the COLUMN area at right

   This field’s data array will display in the columns of your pivot table.

5. In the listed fields place a checkmark on the field you wish to become your numeric data per the categories and series data

   The selected field will place itself in the VALUES area at right.

   **Note:** Anytime data is changed in the range which this pivot table is generated from, you’ll need to refresh the pivot table data. Right-click on the pivot table and choose Refresh.
1. Use the steps on the prior pages to create a Pivot Table
2. Highlight the entire pivot table except the totals column and totals row
3. Click on the Insert Tab and click on the Recommended Charts
4. Choose the appropriate chart type per the type of data comparison/analysis you’re pivot table generates
5. In the top of the window, choose the chart subtype
6. Click on OK

**Note:** Each chart type correlates to a certain type of data comparison or analysis you’re looking to generate. See the following page for chart type definitions.

**Note:** The Column/Series criteria and the Row/Categorical criteria can be filtered within the pivot chart. This feature quickly allows you to adjust the comparisons your making very quickly and easily.
LINE CHART

The line chart is one of the most frequently used chart types, typically used to show trends over a period of time. If you need to chart changes over time, consider using a line chart.

COLUMN CHART

Column charts are typically used to compare several items in a specific range of values. Column charts are ideal if you need to compare a single category of data between individual sub-items, such as, for example, when comparing revenue between regions.

CLUSTERED COLUMN CHART

A clustered column chart can be used if you need to compare multiple categories of data within individual sub-items as well as between sub-items. For instance, you can use a clustered column chart to compare revenue for each year within each region, as well as between regions.
STACKED COLUMN CHART

A stacked column chart allows you to compare items in a specific range of values as well as show the relationship of the individual sub-items with the whole. For instance, a stacked column chart can show not only the overall revenue for each year, but also the proportion of the total revenue made up by each region.

PIE CHART

Another frequently used chart is the old pie chart. A pie chart represents the distribution or proportion of each data item over a total value (represented by the overall pie). A pie chart is most effective when plotting no more than three categories of data.

BAR CHART

Bar charts are typically used to compare several categories of data. Bar charts are ideal for visualizing the distribution or proportion of data items when there are more than three categories. For instance, a bar chart could be used to compare the overall revenue distribution for a given set of products.
AREA CHART

Area charts are ideal for clearly illustrating the magnitude of change between two or more data points. For example, you can give your audience a visual feel for the degree of variance between the high and low price for each month.

![Area Chart](image)

COMBINATION CHART

A combination chart is a visualization that combines two or more chart types into a single chart. Combination charts are an ideal choice when you want to compare two categories of each individual sub-item. They are commonly used to create visualizations that show the difference between targets versus actual results.

![Combination Chart](image)

XY SCATTER PLOT CHART

Scatter charts in Excel (also known as XY scatter plot charts) are excellent for showing correlations between two sets of values. For example, an XY scatter plot can be used to illustrate the correlation between employee performance and competency, demonstrating that employee performance rises as competency improves. The x and y axes work together to represent data plots on the chart based on the intersection of x values and y values.

![XY Scatter Plot Chart](image)
BUBBLE CHART

A bubble chart is a variation of an XY scatter plot. Just like the XY scatter plot, bubble charts show the correlation between two sets of data. The difference is the addition of a third dimension that is represented by the size of each bubble in the chart. This third dimension is typically used to show the relative impact of a quantitative data item. For instance, in addition to showing employee performance versus competency, you can have the size of each bubble represent years of service, allowing your audience to quickly get a sense of how years of service may affect the relationship between competency and performance.
BASIC CONDITIONAL FORMATTING

1. Place your cursor in the cell or highlight a range of cells you wish to assign a Conditional Format.

2. Click on the Home tab, click on the Conditional Formatting button, and select from a range of conditions.

3. In the resulting window select a value and basic cell format to be applied.
   
   Example: Top 10% values in the column will be filled green.

4. Click on OK.

NOTE – Remove Conditional Formats by using the Clear Formats feature in the Conditional Formatting button.

MULTIPLE CONDITIONAL FORMATTING RULES

1. Place your cursor in the cell or highlight a range of cells you wish to assign a Conditional Format.

2. Click on the Home tab, click on the Conditional Formatting button and assign a Conditional Format.

3. Place a second and third Conditional Format for the same cell or range of cells you set the initial format on.

4. You have now assigned multiple Conditional Format rules on the same cell or range of cells.

MANAGING/EDITING RULES

1. Click on the Home tab, click on the Conditional Formatting button, and choose Manage Rules.

   The Conditional Formatting Rules Manager window will appear.

2. In the Show formatting rules for dropdown list, choose the sheet which maintains the conditional formatting rules you wish to edit.

3. Select the rule you wish to edit and click on the Edit Rule… button.

4. Change the rule’s conditions and or change the formatting.
CONDITIONAL FORMATTING – IF CONDITIONS

FORMAT CELLS WHERE OTHER CELLS MEET CONDITIONS

1. Highlight a range of rows you’ll be comparing the conditions of two separate column values.

2. Click on the Home tab, click on the Conditional Formatting button and choose New Rule.

3. In the Conditional Formatting Rules Manager window, select Use a formula to determine which cells to format.

4. In the Format Values entry field create a formula that compares values in two separate cells.
   
   Example: Place a pink color on the selected cells when the value of the Status column is Not Started and the value in the Order Date column is more than 30 days ago.
   
   \[ =\text{AND}(\$G2=\text{"Not Started"},\$D2<\text{TODAY()-30}) \]

5. Click on the Format button and set a basic desired format.

6. Click on OK and OK again.

CREATING IF STATEMENTS

IF AND - If the value in cell D2 is more than 30 days ago AND the value in cell G2 is Not Completed

\[ =\text{AND}(\$G2=\text{"Not Started"},\$D2<\text{TODAY()-30}) \]
BUILD MACRO

If you have tasks in Microsoft Excel that you do repeatedly, you can record a macro to automate those tasks. A macro is an action or a set of actions that you can automate and run as many times as you want.

ENABLE THE DEVELOPER TAB

1. Click on the File tab and click Options
2. Click the Customize Ribbon category
3. Under Customize the Ribbon, in the Main Tabs list, place a check mark on Developer, and click OK

RECORD MACRO

1. Click on the Developer tab and click Record Macro
2. Enter a name for the macro
3. Enter a shortcut key in the Shortcut key and a description in for the macro
4. Click OK to start recording

**Note:** Your macro name cannot contain spaces.
5. Perform the actions you want to automate, such as auto fitting columns, removing columns and formatting row 1
6. On the Developer tab, click Stop Recording

**Note:** Choosing Personal Macro Workbook in the Store macro in: feature will make this macro available in all your workbooks.

RUN MACRO

1. Click on the Developer Tab
2. Click on the Macros button
3. In the Macro window, choose the macro you wish to run
4. Click on Run
VB MARCOS

Macros are actually the result of a set of commands and statements in a computer language known as VB, or Visual Basic. This language is powerful because the it’s the language in which you can customize operations and features in the Microsoft Office. Knowing how to inject VB in the VB editor allows you grab all kinds of macros which have been built by users around the world.

**Note:** You must save your excel file as a Excel Macro-Enabled Workbook in order to save an excel file which maintains macros you’ve create.

**FIND MACRO CODE ON THE WEB**
1. Use a search engine and search the web for “Excel VB Macro Refresh Pivot Table” or some close variation
2. Copy the VB script/code for the stated macro (Sub through End Sub)

**CREATE NEW VB GENERATED MACRO**
1. Click on the Developer tab and click the Macros button
2. Enter a temporary name for the new macro you will create
   Example: MacroA

   **Note:** Your macro name will be replaced when with the name of the VB function you have copied.
3. Click on the Create button
   The Visual Basic for Applications window will display.
   In the Module window you will see you a small piece of code that looks like this:
   ```vb
   Sub MacroA()
   End Sub
   ```
4. In the Module window highlight the current VB code (Sub through End Sub)
5. Press Delete and paste the code you copied from the web
6. Close the Visual Basic for Applications window
7. Click on the Macros button and run your new macro

**Note:** Users initial attempt to open this file will need to enable active content and are prompted with a security waring that the file maintains active content.
PROTECT SHEET

After developing a well built and very functional spreadsheet, you may suffer the fact that other users of this file are breaking it. They may inadvertently delete a formula or change data which should not be changed or even touched. Protecting your sheet will keep this from happening.

UNLOCK USER ENABLED CELLS

1. Select the cells you wish the user to be able to use or edit

   Note: Holding the control key will allow you to highlight multiple ranges at a single time.

2. Click on the Home Tab and click on the Format button
3. Choose Format Cells
4. Click on the Protection Tab
5. Remove the checkmark on Locked
6. Click on OK

The selected cells will remain usable for users once the sheet is protected. All other cells will remain locked and become protected.

PROTECT SHEET

1. Click on the Review Tab
2. Click on the Protect Sheet button

   Note: You can protect all sheets in a workbook with the Protect Workbook feature.

3. Select the features in the list you wish user to be able to do within the sheet
4. Enter a password
5. Click on OK
6. Confirm the password and click on OK

   Note: There is NO password retrieval feature whatsoever for this password feature.

UNPROTECT SHEET

1. Click on the Review Tab
2. Click on the Unprotect Sheet button
3. Enter the password and click on OK
SUPPORT FOR MICROSOFT EXCEL

You may contact the following offices for assistance with Microsoft Excel:

Training – Training Specialists

techtraining@sbcusd.com

(909) 386-2550

OR

Check out the Microsoft Excel Self Help Video Library